[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4559: Invalid argument supplied for foreach()
Dampfradioforum • Thema anzeigen - Transistor-Endstufe schwingt (Motorboating)

Dampfradioforum

Röhrenradioforum: Das Forum für alle Freunde alter Röhrenradios, Kofferradios und Röhrentechnik!
Aktuelle Zeit: Fr Jan 28, 2022 7:32

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 13 Beiträge ] 
Autor Nachricht
BeitragVerfasst: Sa Sep 21, 2019 19:15 
Offline
Benutzeravatar

Registriert: Do Dez 27, 2007 23:19
Beiträge: 9055
Wohnort: östliches Niedersachsen
Kenntnisstand: Sehr gute Kenntnisse (Hobby)
Seit Tagen suche ich einen Fehler im NF-Teil eines französischen Autoradios
https://www.radiomuseum.org/r/conti_edi ... _s191.html
https://www.doctsf.com/continental-edis ... 908/ori=ps
und finde ihn nicht.

Die Endstufe schwingt mit einer Frequenz von ungefähr 40 Hz.

Hier der Schaltplan der Endstufe, den ich herausgezeichnet habe (im Netz findet man ihn nicht):

Dateianhang:
Endstufe.jpg
Endstufe.jpg [ 52.15 KiB | 5010-mal betrachtet ]

Nicht eingezeichnet ist ein 1000 µF-Siebelko an der Betriebsspannung 12V. Und die Vorstufe habe ich nur angedeutet, weil die Ursache dort nicht liegen kann, siehe unten.

Was ich bisher unternommen habe:
- alle Transistoren geprüft, den Treibertransistor (AC128) probeweise gewechselt
- alle Elkos erneuert
- alle Widerstände, einschließlich der beiden Trimmpotis, überprüft
- alle Leiterbahnen und Verbindungen auf mögliche Unterbrechungen oder Kurzschlüsse überprüft
- den 64 µF-Elko links im Schaltplan abgelötet: das Schwingen bleibt, also kommt es nicht aus der Vorstufe
- den Gegenkopplungszweig oben im Bild unterbrochen: das Schwingen bleibt
- den 1000 µF-Elko am Emitter des AC128 abgelötet: die Endstufe schwingt nicht mehr, reagiert aber empfindlich auf Störungen auf der Betriebsspannung
- den 10 Ohm-Widerstand kurzgeschlossen: die Endstufe schwingt nicht mehr, verzerrt aber stark

Das Schwingen setzt ein, wenn der Lautsprecherausgang mit 150 Ohm oder weniger belastet wird. Die Kapazität aller Elkos im gezeichneten Schaltplanausschnitt hat einen Einfluss auf dessen Frequenz.

Das Radio sieht nicht so aus, als hätte schon einmal jemand daran gebastelt. Trotzdem bin ich mir nur zu 98% sicher, das es im Originalzustand ist. Notfalls muss ich auf ein typgleiches Gerät warten, zwecks Vergleich.

Das ist nicht das erste Gerät dieses Typs, das ich auf dem Tisch habe. Die anderen zeigten diesen Effekt auch mit teilweise ausgetrockneten Elkos nicht.

Nun weiß ich nicht mehr weiter. Hat jemand eine Idee, was ich noch überprüfen könnte?

Lutz


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: Sa Sep 21, 2019 19:39 
Offline
Benutzeravatar

Registriert: Di Nov 22, 2011 16:49
Beiträge: 8012
Wohnort: Müritzkreis
Kenntnisstand: Weitergehende Kenntnisse (Hobby)
Moin moin Lutz,
was passiert wenn du die beiden 64µF gegen 100er wechselst ?

_________________
M.f.G.
harry

--------------------------------------------------------------------
- Es ist keine Schande, nichts zu wissen, wohl aber, nichts lernen zu wollen.
--------------------------------------------------------------------


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: Sa Sep 21, 2019 20:12 
Offline
Benutzeravatar

Registriert: Do Dez 27, 2007 23:19
Beiträge: 9055
Wohnort: östliches Niedersachsen
Kenntnisstand: Sehr gute Kenntnisse (Hobby)
Da ich keinen 64 µF-Elko zur Hand hatte, habe ich an beiden Stellen sowohl 47 µF als auch 100 µF eingebaut. Die Frequenz des Schwingens ändert sich etwas, sonst bleibt alles gleich.

Lutz


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: Sa Sep 21, 2019 20:18 
Offline
Benutzeravatar

Registriert: Do Nov 04, 2010 17:42
Beiträge: 2201
Wohnort: 47877 Lavendel-Traumland (NRW)
Kenntnisstand: **Zutreffendes Feld fehlt**
Hallo Lutz,

ich erkenne den Sinn des rechten 64µ zwischen Emitter und Basis-Teiler Anzapf des Treiber-Transistors nicht so richtig. Er verringert nur (sinnlos?) den Eingangswiderstand der Treiberstufe. Was geschieht, wenn du diesen entfernst? Was geschieht, wenn du ihn - Minuspol- an GND legst?

_________________
...und glüht auch die Anode rot, ist die Röhre noch nicht tot.

Mit freundlichen Grüßen, Peter R.


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: Sa Sep 21, 2019 21:12 
Offline
Benutzeravatar

Registriert: Do Dez 27, 2007 23:19
Beiträge: 9055
Wohnort: östliches Niedersachsen
Kenntnisstand: Sehr gute Kenntnisse (Hobby)
Ja, so ganz durchblicke ich diese Schaltung auch nicht. Deinen Vorschlag werde ich voraussichtlich morgen probieren.

Lutz


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: So Sep 22, 2019 16:20 
Offline
Benutzeravatar

Registriert: Do Dez 27, 2007 23:19
Beiträge: 9055
Wohnort: östliches Niedersachsen
Kenntnisstand: Sehr gute Kenntnisse (Hobby)
Hallo Peter,

Du hattest den richtigen Riecher! Mit dem Minuspol des 64 µF an Masse statt am Pluspol des 1000 µF schwingt die Endstufe nicht und arbeitet genau so, wie es sein soll.

Warum man ihn nicht ab Werk so angeschlossen hat, kann ich mir nicht erklären. Unmittelbar daneben gibt es eine Masseleiterbahn, also hätte es nicht einmal einer nennenswerten Layoutänderung bedurft.

Das Radio muss einst mit der Original-Schaltung funktioniert haben. Die einzige Erklärung dafür, die mir einfällt, ist, dass der 1000 µF-Elko ursprünglich vielleicht einen extrem niedrigen ESR hatte, noch niedriger als der Ersatz-Elko, den ich testweise dafür eingebaut hatte.

Kurz und gut, ich werde das jetzt so lassen.

Ohne den 64 µF-Elko schwingt die Endstufe übrigens auch, aber mit einer höheren Frequenz, so um die 60 Hz.

Danke Dir (und allen anderen, die sich Gedanken gemacht haben) und einen schönen Sonntag (oder was noch davon übrig ist...)

Lutz


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: Sa Nov 27, 2021 16:34 
Offline
Benutzeravatar

Registriert: Do Dez 27, 2007 23:19
Beiträge: 9055
Wohnort: östliches Niedersachsen
Kenntnisstand: Sehr gute Kenntnisse (Hobby)
Jetzt hatte ich noch so ein Radio auf dem Tisch. Das hatte ich vor etlichen Jahren schon einmal überholt, damals funktionierte es einwandfrei. Nun zeigte es den gleichen Fehler.

Während ich am Messen war, machte es plötzlich "Knack", und das Brummen war weg. Diverse Versuche, es wieder herbeizuführen, waren erfolglos.

Nun habe ich ein wenig experimentiert. Unter anderem habe ich in Reihe mit den Elkos Widerstände eingefügt, um einen erhöhten ESR zu simulieren. Bei dem 64 µF-Elko, dessen Minuspol ich bei dem anderen Radio umgelegt hatte, setzte bei einem Serienwiderstand von etwa 200 Ohm ein Brummen ein. Wenn der Minuspol des Elkos direkt mit Masse verbunden war, dann erst ab etwa 300 Ohm.

Das Radio unterscheidet sich etwas von dem Exemplar, mit dem ich diesen Thread eröffnet habe: einige Elkos haben andere Werte, und der besagte 64 µF-Elko hatte nur eine Nennspannung von 10 V. Das reicht nicht aus, wenn sein Minuspol direkt an Masse liegt, also habe ich ihn durch einen 100 µF mit höherer Spannungsfestigkeit ersetzt. Um den Minuspol direkt an Masse zu legen, musste ich einige cm Draht ziehen. Bei dem anderen Radio war das nicht nötig, weil gleich neben dem Elko eine Masseleiterbahn vorhanden war.

Also war diese Änderung bei dem anderen Radio nicht nur ein Zufallstreffer, sondern das ist tatsächlich eine Schwäche im Schaltungsdesign dieses Radios.

Lutz


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: Sa Nov 27, 2021 20:49 
Offline

Registriert: Do Nov 17, 2011 23:30
Beiträge: 579
Wohnort: Mannheim
Kenntnisstand: Elektrotechnischer Beruf/ Studium
Hallo zusammen,

diese Schaltung ist nicht besonders tolerant bezüglich Bauteil-Toleranzen. Aber das ist nicht das Thema.

Beim Schwingen muss die Versorgungsspannung (+12 V) beteiligt sein, wenn eine Mitkopplung entstehen soll. Ist von dort kein Elko gegen Masse geschaltet?
Wenn ja, dann ist dessen Serienwiderstand auch zu groß (geworden). Der Laststrom für die positiven Halbwellen fließt durch diesen Kondensator. Dessen Serienwiderstand muss wesentlich geringer sein, als der des Lautsprechers.

Ebenfalls kritisch ist ein Durchgriff der Welligkeit der 12-V-Versorgung auf den Emitter des AC126 in der Vorstufe. Hier genügt sehr geringe Kopplung, um Schwingen anzuregen. Wie der AC126 versorgt wird, ist leider nicht erkennbar.

Bernhard


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: Sa Nov 27, 2021 21:29 
Offline
Benutzeravatar

Registriert: Do Dez 27, 2007 23:19
Beiträge: 9055
Wohnort: östliches Niedersachsen
Kenntnisstand: Sehr gute Kenntnisse (Hobby)
Hallo Bernhard,

an der 12V-Versorgung hängt ein Elko zur Abblockung. Im ersten Gerät hatte er 1000 µF, im aktuellen Gerät 2200 µF. Dieser Elko ist bei beiden Geräten in Ordnung, was aber nicht heißt, dass über diesen Weg keine Kopplung möglich ist.

Die Vorstufe wird auch aus der 12V-Spannung versorgt. Das habe ich nicht im Detail gezeichnet, weil sie an dem Motorboating nicht beteiligt ist: Beim ersten Gerät hatte ich den Koppelelko zwischen Vor- und Endstufe (den linken im Bild) abgelötet, das änderte nichts am Fehlerbild.

Lutz


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: Sa Nov 27, 2021 23:38 
Offline

Registriert: Do Nov 17, 2011 23:30
Beiträge: 579
Wohnort: Mannheim
Kenntnisstand: Elektrotechnischer Beruf/ Studium
röhrenradiofreak hat geschrieben:
Die Vorstufe wird auch aus der 12V-Spannung versorgt. Das habe ich nicht im Detail gezeichnet, weil sie an dem Motorboating nicht beteiligt ist: Beim ersten Gerät hatte ich den Koppelelko zwischen Vor- und Endstufe (den linken im Bild) abgelötet, das änderte nichts am Fehlerbild.

Stimmt, Lutz, damit kann man die Vorstufe und deren Versorgung als Ursache ausschließen.

röhrenradiofreak hat geschrieben:
an der 12V-Versorgung hängt ein Elko zur Abblockung. Im ersten Gerät hatte er 1000 µF, im aktuellen Gerät 2200 µF. Dieser Elko ist bei beiden Geräten in Ordnung, was aber nicht heißt, dass über diesen Weg keine Kopplung möglich ist.

Der Strom für die positive Halbwelle fließt vom Pufferkondensator (1000 µF oder 2200 µF mit Serienwiderstand RS Puffer) über AD161, 1000 µF und den Lautsprecher (RL) zurück zum Pufferkondensator.
Auf der 12-V-Versorgung entsteht die Spannungswelligkeit U = -UAusgang * RS Puffer / RL (negativ, also mit invertierter Phasenlage, weil die Versorgungsspannung sinkt, während die Ausgangsspannung steigt)
Diese Welligkeit kann man nicht vermeiden. Sie ist ungefähr proportional zum Serienwiderstand der Pufferkondensators RS Puffer.

Diese Welligkeit gelangt auf den AC128:
über den Tiefpass 10 Ohm, 1000 µF auf den Emitter und
über den Tiefpass 82 Ohm, 64 µF auf die Basis.
Die Kapazitäten sind sehr groß, haben aber auch geringe Serienwiderstände. Diese wirken mit den Vorwiderständen (10 Ohm bzw. 82 Ohm) als Spannungsteiler.

Der Anteil auf den Emitter des AC128 bleibt gegenphasig, er kann nicht zum Schwingen führen. Hoher Serienwiderstand beim Kondensator 1000 µF erhöht sogar die Stabilität. (Er reduziert aber die Verstärkung.)
Der Anteil auf die Basis des AC128 wird vom AC128 nochmal invertiert und ist damit gleichphasig zum Ausgang. Hoher Serienwiderstand beim Kondensator 64 µF reduziert die Stabilität.
-> Der Serienwiderstand des Kondensators 64 µF muss gering sein.

Die Schaltung bleibt stabil (unabhängig vom Serienwiderstand des Pufferkondensators), wenn der Serienwiderstand des Kondensators 64 µF kleiner ist als 82 Ohm / 10 Ohm = 8,2 Mal dem Serienwiderstand des Kondensators 1000 µF. Dann ist die Gegenkopplung stärker als die Mitkopplung.
Darüber kommt das Produkt aus Verstärkung des AC128 mal Abschwächung durch RS Puffer / RL hinzu.
-> Bei hohem Serienwiderstand des Kondensators 64 µF ist die Schwingneigung abhängig von RS Puffer und von RL.

Bernhard


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: So Nov 28, 2021 10:51 
Offline
Benutzeravatar

Registriert: Do Dez 27, 2007 23:19
Beiträge: 9055
Wohnort: östliches Niedersachsen
Kenntnisstand: Sehr gute Kenntnisse (Hobby)
Super erklärt!

Hat der Konstukteur etwa eine Kompensation der gegenphasigen Anteile versucht, indem er den Minus des 64 µF nicht direkt an Masse, sondern an den Plus des 1000 µF gelegt hat? Das hat jedenfalls nicht funktioniert.

Ich habe mal den Serienwiderstand der beiden Elkos am Collector und Emitter des AC128 gemessen. Der 64 µF hat einen Serienwiderstand von knapp 2 Ohm, der 1000 µF von unter 0,2 Ohm (gemessen bei einer Frequenz im kHz-Bereich, denn bei 40 Hz überwiegt dier kapazitive Scheinwiderstand besonders des 64 µF derart, dass ich den Serienwiderstand nicht mehr messen kann). Aber es entspricht ungefähr Deiner Rechnung.

Das ganze ist an den ausgebauten Elkos gemessen. Um die neuen Elkos zu messen, müsste ich das Radio noch einmal auseinanderbauen. Weil das Aufsetzen des Gehäuses eine üble Fummelei ist, werde ich mir das ersparen.

Lutz


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: So Nov 28, 2021 15:52 
Offline

Registriert: Do Nov 17, 2011 23:30
Beiträge: 579
Wohnort: Mannheim
Kenntnisstand: Elektrotechnischer Beruf/ Studium
Mit 64 µF an Masse statt am Emitter müsste – nach meinem Schaltungsverständnis – die Schwingneigung etwas abnehmen. Die Grenze für das Verhältnis der Elko-Serienwiderstände steigt dann von 82 Ohm / 10 Ohm = 8,2 auf 82 Ohm / 10 Ohm + 1 = 9,2.

Auch über diesem Verhältnis ist dann die Dämpfung im "Schwingkreis" um 12 % stärker.

Diesen Unterschied wird man aber nur bemerken, wenn die Werte gerade in dem Bereich liegen, in dem das Schwingen einsetzt.

Aus meiner Sicht macht es schon Sinn, das Basispotential des AC128 wechselstrommäßig am Emitter anzubinden, statt an Masse. Bei niederfrequenten Änderungen der Versorgungsspannung und damit auch der Emitterspannung, läuft der Minusanschluss des 64-µF-Kondensators mit und der 82-Ohm-Widerstand muss den Kondensator weniger umladen. Und beim Einschalten werden die Arbeitspunkte schneller erreicht.

Bei meiner Abschätzung zum Schaltungsverständnis und der Schwingneigung habe ich jeweils viele Eigenschaften vernachlässigt, auch beispielsweise, dass die Mitkopplung für beide Halbwellen unterschiedlich ist. also nimm die Werte nicht als genau an, nur als Trend.

Serienwiderstände von 2 Ohm bzw. 0,2 Ohm sind durchaus realistisch, wobei ich den Serienwiderstand des alten 64-µF-Kondensators durchaus höher geschätzt habe.
Vielleicht ist der Widerstand 82 Ohm an einer ungünstigen Stelle angeschlossen oder der große Pufferkondensator hat relativ "hochohmige" Verbindung zur Versorgung oder zum Massepotential.

Ob sich der Konstrukteur Gedanken zur Stabilität machte, kann ich nicht sagen. Jedenfalls habe ich mit vier Transistoren schon "stabilere" NF-Verstärker gesehen, bei denen sich die Mittenspannung automatisch einstellt, weniger abhängig ist von Bauteileigenschaften und die dann auch nur ein Poti (für den Ruhestrom) benötigen.

Bernhard


Nach oben
 Profil  
Mit Zitat antworten  
BeitragVerfasst: So Nov 28, 2021 17:26 
Offline
Benutzeravatar

Registriert: Do Dez 27, 2007 23:19
Beiträge: 9055
Wohnort: östliches Niedersachsen
Kenntnisstand: Sehr gute Kenntnisse (Hobby)
Das Radio stammt aus der Mitte der 60er Jahre und ist somit eines der ersten mit eisenloser Endstufe. Da gab es noch Optimierungspotential. Sicher wird sich der Konstrukteur Gedanken um die Stabilität gemacht haben, aber manche Schaltungstricks haben sich erst im Laufe der Jahre durchgesetzt.

Mit dem 64µF an Masse statt am Emitter ist die Schwingneigung etwas geringer, das ist richtig. Eine erhöhte Empfindlichkeit gegenüber Störungen auf der Versorgungsspannung konnte ich nicht feststellen. Das liegt vielleicht auch daran, dass es am Betriebsspannungseingang, also vor dem 2200 µF-Elko, eine ziemlich dicke Drossel gibt.

Vielleicht war der Serienwiderstand zunächst höher und hat in dem Augenblick, als die Schwingung plötzlich verschwand, schlagartig abgenommen.

Wie auch immer, das Radio spielt nun wie es soll, und ich werde es so lassen.

Lutz


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 13 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
POWERED_BY
Deutsche Übersetzung durch phpBB.de

 
Impressum